// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\((\d+),\s*?((?:'[^']*?',\s*?)+)\s*?'([^']*?)',\s*?'([^']*?)'\)").unwrap();
let string = "INSERT INTO `dle_post` (`id`, `short_story`, `full_story`, `title`, `descr`, `category`, `alt_name`, `editdate`) VALUES
(39, '<p><!--dle_image_begin:http://site.ru/uploads/posts/2011-01/1294417051_220px-taisha-abelar-01.jpg|left--><img src=\"http://site.ru/uploads/posts/2011-01/1294417051_220px-taisha-abelar-01.jpg\" align=\"left\" alt=\"Лекция Тайши Абеляр (1994г.)\" title=\"Лекция Тайши Абеляр (1994г.)\" /><!--dle_image_end--><br /><br />Каждый из нас может \\\\\"видеть\\\\\" энергию, прямо сейчас, но вы более не осознаете это. Младенцы, в противоположность нам, воспринимают энергию напрямую. Однако когда они становятся старше, \\\\\"Проводник\\\\\" вводит их в мир обычной реальности. Вместо наблюдения аморфной энергии, ребенок однажды сведет ее конфигурации в... таблицу. Игрушку. Собаку. Дерево. Каждое такое преобразование приходит от Проводника.</p>', 'full_story (Дохрена текста с разнообразными символа и прочим)', 'title', 'descr', '194', 'lekciya-tayshi-abelyar-1994g', '1401365620'),
";
let substitution = "\\($1, $2 '$1-$3.html', $4\\)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}