re = /^(\|*(?:(?!\|\|(?!.*\|\|)).)*)/m
str = 'a|b|c|d
a|b||c||d
a|b||c|d
|||a|b||c||d
|||a|b||c|a||e
||||a|b||c|a||f
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end