package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(@\S+)\s+(\S+)`)
var str = `@name Home @options {} @include h1,h2,h3 @exclude p,div,em`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}