$re = '/(@\S+)\s+(\S+)/';
$str = '@name Home @options {} @include h1,h2,h3 @exclude p,div,em';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);