use strict;
my $str = 'ABC
44234234
GHG
FGyhyh
Nov2016
/////////////////////////
ABCtt
44234234
GHG
00
FGyhyh
Nov2015
/////////////////////////
ABC
44234234
GHG
hyh
Jan2022
/////////////////////////';
my $regex = qr/^(?:[A-Za-z\d].*\R)+?(?:[A-Za-z].*\R){2}(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\d{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}