#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\D{2}\d{2}-\d{6}\b"
Local $sString = "АБА00-000001 то получается БА00-000001" & @CRLF & _
"АА00-0001010 то получается АА00-000101" & @CRLF & _
"они нужны для отлова таких кодов АА00-000001 и вроде как работает, хотя и 0000-000001 тоже отлавливает." & @CRLF & _
"а вот если такая конструкция" & @CRLF & _
"а такие вообще не должно брать." & @CRLF & _
"Помогите как правильно написать ее."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")