$re = '/\D{2}\d{2}-\d{6}\b/m';
$str = 'АБА00-000001 то получается БА00-000001
АА00-0001010 то получается АА00-000101
они нужны для отлова таких кодов АА00-000001 и вроде как работает, хотя и 0000-000001 тоже отлавливает.
а вот если такая конструкция
а такие вообще не должно брать.
Помогите как правильно написать ее.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);