# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/0*(?:\+?972)?(?<tel>\d+)/0${tel}/g;t' <<< "0527691234
00527691234
527691234
00972527691234
972527691234
+972527691234
"