#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d?\d(?::\d\d)?\s*[ap]m(?:\s*-\s*\d?\d(?::\d\d)?\s*[ap]m)\b"
Local $sString = "Mon-Thu, Sun 11:30 am - 9 pm" & @CRLF & _
"Sat-Sun 9:30 am - 9:30 pm" & @CRLF & _
"Sat 5 pm - 9 pm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")