import re
regex = re.compile(r"\b\d?\d(?::\d\d)?\s*[ap]m(?:\s*-\s*\d?\d(?::\d\d)?\s*[ap]m)\b", flags=re.MULTILINE)
test_str = ("Mon-Thu, Sun 11:30 am - 9 pm\n"
"Sat-Sun 9:30 am - 9:30 pm\n"
"Sat 5 pm - 9 pm")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")