$re = '/([\w+\[\]]+)(?=\([\w+,]*\))/m';
$str = 'this is a test() and im() testing() thi[s]() this_[is]_a_fun(with,some,params)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);