re = /([\w+\[\]]+)(?=\([\w+,]*\))/m
str = 'this is a test() and im() testing() thi[s]() this_[is]_a_fun(with,some,params)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end