$re = '/^.*(?!@mydomain\.de$)@[^.]+(?:\.[^.]+)+$/m';
$str = 'nomatch@mydomain.de
match@somedomain.com
anothermatch@other.domain.us';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);