re = /^.*(?!@mydomain\.de$)@[^.]+(?:\.[^.]+)+$/m
str = 'nomatch@mydomain.de
match@somedomain.com
anothermatch@other.domain.us'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end