#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(-?)[$€]?(\d+(?:[,.]\d+)*)"
Local $sString = "null" & @CRLF & _
"null" & @CRLF & _
"($7.08 CAD)" & @CRLF & _
"(-$1.06 CAD)" & @CRLF & _
"(€50.03 EUR)" & @CRLF & _
"($1,024.38 CAD)" & @CRLF & _
"(-$1,024,309.06 CAD)" & @CRLF & _
"(€50.03 EUR)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")