import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-?)[$€]?(\\d+(?:[,.]\\d+)*)";
final String string = "null\n"
+ "null\n"
+ "($7.08 CAD)\n"
+ "(-$1.06 CAD)\n"
+ "(€50.03 EUR)\n"
+ "($1,024.38 CAD)\n"
+ "(-$1,024,309.06 CAD)\n"
+ "(€50.03 EUR)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}