package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(00989|\+989|09)(\d{9})$`)
var str = `09396790309`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}