$re = '/^(00989|\+989|09)(\d{9})$/m';
$str = '09396790309';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);