package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^value=(\/(path1|path2)|\\${VAR})\/?$`)
var str = `value=/path1
value=/path2
value=/path1/
value=/path2/
value=${VAR}
value=${VAR}/
value=$VAR
value=$VAR/
value=/path1/foo
value=/path2/foo
value=${VAR}/foo
value=$VAR/foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}