import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^value=(\\/(path1|path2)|\\\\$\\{VAR\\})\\/?$";
final String string = "value=/path1\n"
+ "value=/path2\n"
+ "value=/path1/\n"
+ "value=/path2/\n"
+ "value=${VAR}\n"
+ "value=${VAR}/\n"
+ "value=$VAR\n"
+ "value=$VAR/\n"
+ "value=/path1/foo\n"
+ "value=/path2/foo\n"
+ "value=${VAR}/foo\n"
+ "value=$VAR/foo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}