const regex = /^(?'asset'02)_(?'market1'\w{3,})\/(?'market2'\w{3,})_(?'type'CY)(?'offset'L)_(?'derivative'PHY|FUT) (?'period')(?'year'\d{4})\b$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?\'asset\'02)_(?\'market1\'\\w{3,})\\\/(?\'market2\'\\w{3,})_(?\'type\'CY)(?\'offset\'L)_(?\'derivative\'PHY|FUT) (?\'period\')(?\'year\'\\d{4})\\b$', 'gm')
const str = `02_AUT/TTF_H_CYL_PHY 2015
02_AUT/TTF_H_CYL_PHY 2016
02_GASPOOL_L/GASPOOL_H_CYL_PHY 2015
02_GASPOOL_L/GASPOOL_H_CYL_PHY 2016`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}