const regex = /(\d{1,2})h(?:\s?(\d{1,2})m)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2})h(?:\\s?(\\d{1,2})m)?', 'g')
const str = `8h 20m left
42m left
7h left
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}