#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((?(2)\2\2|.))*x)(?!\1)((?(3)\3\3|.))*x$|^(((?(5)\5{10}|.{9}))*x)(?!\4)((?(6)\6{10}|.{9}))*x$"
Local $sString = "x" & @CRLF & _
"xx" & @CRLF & _
"xxx" & @CRLF & _
"xxxx" & @CRLF & _
"xxxxx" & @CRLF & _
"xxxxxx" & @CRLF & _
"xxxxxxx" & @CRLF & _
"xxxxxxxx" & @CRLF & _
"xxxxxxxxx" & @CRLF & _
"xxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")