import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((?(2)\\2\\2|.))*x)(?!\\1)((?(3)\\3\\3|.))*x$|^(((?(5)\\5{10}|.{9}))*x)(?!\\4)((?(6)\\6{10}|.{9}))*x$";
final String string = "x\n"
+ "xx\n"
+ "xxx\n"
+ "xxxx\n"
+ "xxxxx\n"
+ "xxxxxx\n"
+ "xxxxxxx\n"
+ "xxxxxxxx\n"
+ "xxxxxxxxx\n"
+ "xxxxxxxxxx\n"
+ "xxxxxxxxxxx\n"
+ "xxxxxxxxxxxx\n"
+ "xxxxxxxxxxxxx\n"
+ "xxxxxxxxxxxxxx\n"
+ "xxxxxxxxxxxxxxx\n"
+ "xxxxxxxxxxxxxxxx\n"
+ "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx\n"
+ "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx\n"
+ "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}