#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ +([\w+ ]+)|(\$\d+\.\d+)"
Local $sString = "SUBCONTRACTOR NAME Invoice" & @CRLF & _
"" & @CRLF & _
"PO Box 000 Date Invoice #" & @CRLF & _
"CITY, STATE 11111 7/15/2020 34825" & @CRLF & _
"email@addre.ess.com" & @CRLF & _
"" & @CRLF & _
" Bill To" & @CRLF & _
" Company Name" & @CRLF & _
" Jill Sample Name" & @CRLF & _
" 2 A Road Name Ct" & @CRLF & _
" A Town, SS 11111" & @CRLF & _
"" & @CRLF & _
" P.O. No. Terms Project" & @CRLF & _
"" & @CRLF & _
" Due on receipt" & @CRLF & _
"" & @CRLF & _
"Item Description Est Amt Prior Amt Prior % Qty Rate Curr % Total % Amount" & @CRLF & _
" 42.00 1 42.00T" & @CRLF & _
"15 C Su... Summer Application 42.00 100.00% 100.00%" & @CRLF & _
" * Fertilizer" & @CRLF & _
" * Broadleaf weed control" & @CRLF & _
"" & @CRLF & _
" Total before discounts and sales 126.00 33.33% 33.33% 42.00" & @CRLF & _
" tax" & @CRLF & _
"" & @CRLF & _
" Subtotal $42.00" & @CRLF & _
" Sales Tax (0.0%) $0.00" & @CRLF & _
" Total" & @CRLF & _
" Payments/Credits $42.00" & @CRLF & _
" $0.00" & @CRLF & _
" Balance Due" & @CRLF & _
" $42.00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")