re = /^ +([\w+ ]+)|(\$\d+\.\d+)/m
str = 'SUBCONTRACTOR NAME Invoice
PO Box 000 Date Invoice #
CITY, STATE 11111 7/15/2020 34825
email@addre.ess.com
Bill To
Company Name
Jill Sample Name
2 A Road Name Ct
A Town, SS 11111
P.O. No. Terms Project
Due on receipt
Item Description Est Amt Prior Amt Prior % Qty Rate Curr % Total % Amount
42.00 1 42.00T
15 C Su... Summer Application 42.00 100.00% 100.00%
* Fertilizer
* Broadleaf weed control
Total before discounts and sales 126.00 33.33% 33.33% 42.00
tax
Subtotal $42.00
Sales Tax (0.0%) $0.00
Total
Payments/Credits $42.00
$0.00
Balance Due
$42.00
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end