package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d+(?:\.\d+)?(?:[KMG]i)?\b`)
var str = `14.4Mi, 9.9Gi, 10Ki
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}