$re = '/\b\d+(?:\.\d+)?(?:[KMG]i)?\b/';
$str = '14.4Mi, 9.9Gi, 10Ki
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);