using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\/][q]\w+[\.][h][>]";
string input = @"#include <QtCore/qdir.h>
#include <QtCore/QDir>
#include <QtCore/QDir.h>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}