const regex = /[\/][q]\w+[\.][h][>]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\\/][q]\\w+[\\.][h][>]', 'g')
const str = `#include <QtCore/qdir.h>
#include <QtCore/QDir>
#include <QtCore/QDir.h>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}