$re = '/(?:@|\(|,\s*|="?)(\w+)(?=\(|=|"|\))/m';
$str = '@Apple(kind="Bax", priority=33)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);