re = /(?:@|\(|,\s*|="?)(\w+)(?=\(|=|"|\))/m
str = '@Apple(kind="Bax", priority=33)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end