use strict;
my $str = 'Mexico (01) 55 1234 5678
Mexico (55) 1234 5678
Germany +49 30 2415889
UK +44 20 7930 7530
U.S.A. +1 503-225-5555
U.S.A. +1 503.225.5555
U.S.A. +001 503 225 5555
South Africa +27 21 419 3715
South Africa (+27) 21 419 3715
Japan +81 3-3211-3677
Japan +81 0112716677
Netherlands +31 20 610 9067
France +33 1 44 52 71 73
Australia +61 2 9669 3885
Australia (06) 1234 1234
Australia 0444 123 123
Spain +34 934 12 70 31
Spain 934 12 70 31
Portugal +351 21 846 1081
+81 3-3211-3677 ext. 12
+81 3-3211-3677 x 12
+81 3-3211-3677 extention 12
1231231233';
my $regex = qr/^(\d{10,21})|(\+\d{1,3}|\d{1,4}|\(\+\d{1,3}\)|\(\d{1,2}\))(([ -.]\d+){1,5}$|([ -.]\d+){1,5}([ -.](ext\.|x|extention))[ -.]\d{1,5}$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}