import Foundation
let pattern = #"^(\d{10,21})|(\+\d{1,3}|\d{1,4}|\(\+\d{1,3}\)|\(\d{1,2}\))(([ -.]\d+){1,5}$|([ -.]\d+){1,5}([ -.](ext\.|x|extention))[ -.]\d{1,5}$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Mexico (01) 55 1234 5678
Mexico (55) 1234 5678
Germany +49 30 2415889
UK +44 20 7930 7530
U.S.A. +1 503-225-5555
U.S.A. +1 503.225.5555
U.S.A. +001 503 225 5555
South Africa +27 21 419 3715
South Africa (+27) 21 419 3715
Japan +81 3-3211-3677
Japan +81 0112716677
Netherlands +31 20 610 9067
France +33 1 44 52 71 73
Australia +61 2 9669 3885
Australia (06) 1234 1234
Australia 0444 123 123
Spain +34 934 12 70 31
Spain 934 12 70 31
Portugal +351 21 846 1081
+81 3-3211-3677 ext. 12
+81 3-3211-3677 x 12
+81 3-3211-3677 extention 12
1231231233
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)