package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+='[^']*'`)
var str = `[testing att1='hello' att2='hello again' att3='£100']`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}