$re = '/\w+=\'[^\']*\'/m';
$str = '[testing att1=\'hello\' att2=\'hello again\' att3=\'£100\']';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);