$re = '/(?<=\d[.])\d+(?=\.\d+\/)/m';
$str = 'https://example.com/repository/local/foo-bar/2.15290.0/foo_bar-2.15290.0.tar.gz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);