re = /(?<=\d[.])\d+(?=\.\d+\/)/m
str = 'https://example.com/repository/local/foo-bar/2.15290.0/foo_bar-2.15290.0.tar.gz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end