$re = '~^(?:[^/]*/){2}([^/]+)~im';
$str = 'SN=8029758034.Ref=BFO7Y95B3KN5#resolved/NC339/V928/ClearenceBBF.Brief@{supervisor}/verified
SN=1395939213.#variable/OGT84/PKXC/Undetermined.Thank You@{customer}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);