import re
regex = re.compile(r"^(?:[^/]*/){2}([^/]+)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("SN=8029758034.Ref=BFO7Y95B3KN5#resolved/NC339/V928/ClearenceBBF.Brief@{supervisor}/verified\n"
"SN=1395939213.#variable/OGT84/PKXC/Undetermined.Thank You@{customer}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")