import re
regex = re.compile(r"filename=\"?(\S*\.\w*)", flags=re.IGNORECASE)
test_str = ("\n"
"attachment; filename=\"科学上网.pdf\"; filename*=utf-8''科学上网.pdf\n\n\n"
"attachment; fileName=科学上网.pdf")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")