const regex = new RegExp('TOTAL LEI (?P<TotalLei>\\d+\\.\\d+)\\s.*iD BF: (?P<iD_BF>\\d+\\s\\d\\s\\d+)\\s.*DATA: (?P<DATA>[^\\s]+)\\s', 'gm')
const str = `TOTAL LEI 90.00 | CARD 50.00 REST 0.00 TOTAL TUA A - 19% 1.92 TOTAL TAC - 5% al TOTAL TUA BON 3.73 2:0764 BF +0049 AR. ANEF 0001, iD BF: 3000856168202 1 129015100807640049 DATA: 30-12-2021 ORA: 15:10:08`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}