package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)\s<.*?>(?:,\s)?`)
var str = `name1 <email1@email.com>, name2 <email2@email.com>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}