$re = '/(\w+)\s<.*?>(?:,\s)?/m';
$str = 'name1 <email1@email.com>, name2 <email2@email.com>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);