package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(3[01]|[12][0-9]|[1-9])$`)
var str = `0
12
1
32
33
30
29`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}