$re = '/^(3[01]|[12][0-9]|[1-9])$/m';
$str = '0
12
1
32
33
30
29';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);