package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:/[^/]+)+?/\w+\.\w+`)
var str = `file path /log/file.txt some lines /log/var/file2.txt
/log////var////.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}