$re = '/(?:/[^/]+)+?/\w+\.\w+/m';
$str = 'file path /log/file.txt some lines /log/var/file2.txt
/log////var////.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);