$re = '/Py(th)*/m';
$str = 'Python language
python algorithm
code Pytthon
Python script
more repetitions Pyththththtthon
zero occurrences Py Pyttt-pyPyth ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);