re = /Py(th)*/m
str = 'Python language
python algorithm
code Pytthon
Python script
more repetitions Pyththththtthon
zero occurrences Py Pyttt-pyPyth '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end